use strict;
my $str = 'AAA PCSK-9, $111 -3,33
PCSK-9£12
PCSK-9 £12
Test €234 test€455 test -100,00 -€1999.00test';
my $regex = qr/(?<!\S)-?[$€£]?(\d+(?:[,.]\d+)?)(?!\S)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}