using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)-?[$€£]?(\d+(?:[,.]\d+)?)(?!\S)";
string input = @"AAA PCSK-9, $111 -3,33
PCSK-9£12
PCSK-9 £12
Test €234 test€455 test -100,00 -€1999.00test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}