#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Name\s?\:(\s+)?)[A-z]+(?=(\s+)?Date)"
Local $sString = "Name:James Date : 09/04/22" & @CRLF & _
"" & @CRLF & _
"Name : Mary Date : 09/04/22" & @CRLF & _
"" & @CRLF & _
"Name : Tom Date : 09/04/22" & @CRLF & _
"" & @CRLF & _
"Address : America Date : 09/04/22" & @CRLF & _
"" & @CRLF & _
"Address : United Kingdom Date : 09/04/22"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")