re = /(?<=Name\s?\:(\s+)?)[A-z]+(?=(\s+)?Date)/m
str = 'Name:James Date : 09/04/22
Name : Mary Date : 09/04/22
Name : Tom Date : 09/04/22
Address : America Date : 09/04/22
Address : United Kingdom Date : 09/04/22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end