using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Name\s?\:(\s+)?)[A-z]+(?=(\s+)?Date)";
string input = @"Name:James Date : 09/04/22
Name : Mary Date : 09/04/22
Name : Tom Date : 09/04/22
Address : America Date : 09/04/22
Address : United Kingdom Date : 09/04/22";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}