import re
regex = re.compile(r"(?<=Name\s?\:(\s+)?)[A-z]+(?=(\s+)?Date)", flags=re.MULTILINE)
test_str = ("Name:James Date : 09/04/22\n\n"
"Name : Mary Date : 09/04/22\n\n"
"Name : Tom Date : 09/04/22\n\n"
"Address : America Date : 09/04/22\n\n"
"Address : United Kingdom Date : 09/04/22")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")