import Foundation
let pattern = #"(?<=Name\s?\:(\s+)?)[A-z]+(?=(\s+)?Date)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Name:James Date : 09/04/22
Name : Mary Date : 09/04/22
Name : Tom Date : 09/04/22
Address : America Date : 09/04/22
Address : United Kingdom Date : 09/04/22
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)