#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!^(0{1,3}\.?)+(,00)?$)(\d{1,3}\.?)+(,\d\d?)?"
Local $sString = "0,00" & @CRLF & _
"00,00" & @CRLF & _
"000,00" & @CRLF & _
"0.000,00" & @CRLF & _
"0,01 -- true" & @CRLF & _
"0,10 -- true" & @CRLF & _
"1,00 -- true" & @CRLF & _
"10,00 -- true" & @CRLF & _
"100,00 - true" & @CRLF & _
"1.000,00 -- true" & @CRLF & _
"10.000,00 -- true" & @CRLF & _
"100.000,00 --true" & @CRLF & _
"1.000.000,00 -- true" & @CRLF & _
"10.000.000,00 -- true" & @CRLF & _
"100.000.000,00 -- true" & @CRLF & _
"1.000.000.000,00 -- true" & @CRLF & _
"" & @CRLF & _
"0,00" & @CRLF & _
"00,00" & @CRLF & _
"000,00" & @CRLF & _
"0000,00" & @CRLF & _
"0,01 -- true" & @CRLF & _
"0,10 -- true" & @CRLF & _
"1,00 -- true" & @CRLF & _
"10,00 -- true" & @CRLF & _
"100,00 - true" & @CRLF & _
"1000,00 -- true" & @CRLF & _
"10000,00 -- true" & @CRLF & _
"100000,00 --true" & @CRLF & _
"1000000,00 -- true" & @CRLF & _
"10000000,00 -- true" & @CRLF & _
"100000000,00 -- true" & @CRLF & _
"1000000000,00 -- true"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")