using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!^(0{1,3}\.?)+(,00)?$)(\d{1,3}\.?)+(,\d\d?)?";
string input = @"0,00
00,00
000,00
0.000,00
0,01 -- true
0,10 -- true
1,00 -- true
10,00 -- true
100,00 - true
1.000,00 -- true
10.000,00 -- true
100.000,00 --true
1.000.000,00 -- true
10.000.000,00 -- true
100.000.000,00 -- true
1.000.000.000,00 -- true
0,00
00,00
000,00
0000,00
0,01 -- true
0,10 -- true
1,00 -- true
10,00 -- true
100,00 - true
1000,00 -- true
10000,00 -- true
100000,00 --true
1000000,00 -- true
10000000,00 -- true
100000000,00 -- true
1000000000,00 -- true";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}