import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!^(0{1,3}\\.?)+(,00)?$)(\\d{1,3}\\.?)+(,\\d\\d?)?";
final String string = "0,00\n"
+ "00,00\n"
+ "000,00\n"
+ "0.000,00\n"
+ "0,01 -- true\n"
+ "0,10 -- true\n"
+ "1,00 -- true\n"
+ "10,00 -- true\n"
+ "100,00 - true\n"
+ "1.000,00 -- true\n"
+ "10.000,00 -- true\n"
+ "100.000,00 --true\n"
+ "1.000.000,00 -- true\n"
+ "10.000.000,00 -- true\n"
+ "100.000.000,00 -- true\n"
+ "1.000.000.000,00 -- true\n\n"
+ "0,00\n"
+ "00,00\n"
+ "000,00\n"
+ "0000,00\n"
+ "0,01 -- true\n"
+ "0,10 -- true\n"
+ "1,00 -- true\n"
+ "10,00 -- true\n"
+ "100,00 - true\n"
+ "1000,00 -- true\n"
+ "10000,00 -- true\n"
+ "100000,00 --true\n"
+ "1000000,00 -- true\n"
+ "10000000,00 -- true\n"
+ "100000000,00 -- true\n"
+ "1000000000,00 -- true";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}