import Foundation
let pattern = #"^(?!^(0{1,3}\.?)+(,00)?$)(\d{1,3}\.?)+(,\d\d?)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0,00
00,00
000,00
0.000,00
0,01 -- true
0,10 -- true
1,00 -- true
10,00 -- true
100,00 - true
1.000,00 -- true
10.000,00 -- true
100.000,00 --true
1.000.000,00 -- true
10.000.000,00 -- true
100.000.000,00 -- true
1.000.000.000,00 -- true
0,00
00,00
000,00
0000,00
0,01 -- true
0,10 -- true
1,00 -- true
10,00 -- true
100,00 - true
1000,00 -- true
10000,00 -- true
100000,00 --true
1000000,00 -- true
10000000,00 -- true
100000000,00 -- true
1000000000,00 -- true
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)