#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9]+(?:(?:[\r\n]+|,)[a-zA-Z0-9]+){0,19}$"
Local $sString = "FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02" & @CRLF & _
"" & @CRLF & _
"FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02" & @CRLF & _
"" & @CRLF & _
"FVO01,FVO02,FVO03" & @CRLF & _
"FVO01" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"FVO02" & @CRLF & _
"" & @CRLF & _
"FVO03" & @CRLF & _
"FVO01,FVO02,FVO03" & @CRLF & _
"FVO01" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"FVO02" & @CRLF & _
"" & @CRLF & _
"FVO03" & @CRLF & _
"FVO01,FVO02,FVO03" & @CRLF & _
"FVO01" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"FVO02" & @CRLF & _
"" & @CRLF & _
"FVO03,FVO03,FVO03" & @CRLF & _
"" & @CRLF & _
"FVO01,FVO02" & @CRLF & _
"" & @CRLF & _
"FVO01,FVO02,FVO03" & @CRLF & _
"FVO01" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"FVO02" & @CRLF & _
"" & @CRLF & _
"FVO03" & @CRLF & _
"FVO01,FVO02,FVO03" & @CRLF & _
"FVO01" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"FVO02" & @CRLF & _
"" & @CRLF & _
"FVO03" & @CRLF & _
"FVO01,FVO02,FVO03" & @CRLF & _
"FVO01" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")