re = /^[a-zA-Z0-9]+(?:(?:[\r\n]+|,)[a-zA-Z0-9]+){0,19}$/m
str = 'FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02
FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03,FVO03,FVO03
FVO01,FVO02
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end