import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9]+(?:(?:[\\r\\n]+|,)[a-zA-Z0-9]+){0,19}$";
final String string = "FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02\n\n"
+ "FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02\n\n"
+ "FVO01,FVO02,FVO03\n"
+ "FVO01\n\n\n\n"
+ "FVO02\n\n"
+ "FVO03\n"
+ "FVO01,FVO02,FVO03\n"
+ "FVO01\n\n\n\n"
+ "FVO02\n\n"
+ "FVO03\n"
+ "FVO01,FVO02,FVO03\n"
+ "FVO01\n\n\n\n"
+ "FVO02\n\n"
+ "FVO03,FVO03,FVO03\n\n"
+ "FVO01,FVO02\n\n"
+ "FVO01,FVO02,FVO03\n"
+ "FVO01\n\n\n\n"
+ "FVO02\n\n"
+ "FVO03\n"
+ "FVO01,FVO02,FVO03\n"
+ "FVO01\n\n\n\n"
+ "FVO02\n\n"
+ "FVO03\n"
+ "FVO01,FVO02,FVO03\n"
+ "FVO01\n\n\n\n"
+ "FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}