using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9]+(?:(?:[\r\n]+|,)[a-zA-Z0-9]+){0,19}$";
string input = @"FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02
FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03,FVO03,FVO03
FVO01,FVO02
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}