package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9]+(?:(?:[\r\n]+|,)[a-zA-Z0-9]+){0,19}$`)
var str = `FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02
FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03,FVO03,FVO03
FVO01,FVO02
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}