$re = '/^[a-zA-Z0-9]+(?:(?:[\r\n]+|,)[a-zA-Z0-9]+){0,19}$/m';
$str = 'FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02
FVO01,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02,FVO03,FVO02,FVO02
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03,FVO03,FVO03
FVO01,FVO02
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02
FVO03
FVO01,FVO02,FVO03
FVO01
FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02,FVO02
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);