# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\r?\n)\s*\+\s*(?=\d{2}[- \\/.]\d{2}[- \\/.]\d{4})|\r?\n\s*\+\s*/$1/gm;t' <<< "22/03/2012 intro
+ 22/03/2012 body
+ more body
"