const regex = /(\r?\n)\s*\+\s*(?=\d{2}[- \/.]\d{2}[- \/.]\d{4})|\r?\n\s*\+\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\r?\\n)\\s*\\+\\s*(?=\\d{2}[- \\\/.]\\d{2}[- \\\/.]\\d{4})|\\r?\\n\\s*\\+\\s*', 'gm')
const str = `22/03/2012 intro
+ 22/03/2012 body
+ more body
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);