import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\r?\\n)\\s*\\+\\s*(?=\\d{2}[- \\/.]\\d{2}[- \\/.]\\d{4})|\\r?\\n\\s*\\+\\s*";
final String string = "22/03/2012 intro\n"
+ " + 22/03/2012 body\n"
+ " + more body\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}