re = /(\r?\n)\s*\+\s*(?=\d{2}[- \/.]\d{2}[- \/.]\d{4})|\r?\n\s*\+\s*/m
str = '22/03/2012 intro
+ 22/03/2012 body
+ more body
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result