use strict;
my $str = '22/03/2012 intro
+ 22/03/2012 body
+ more body
';
my $regex = qr/(\r?\n)\s*\+\s*(?=\d{2}[- \/.]\d{2}[- \/.]\d{4})|\r?\n\s*\+\s*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";