import re
regex = re.compile(r"(\r?\n)\s*\+\s*(?=\d{2}[- \/.]\d{2}[- \/.]\d{4})|\r?\n\s*\+\s*", flags=re.MULTILINE)
test_str = ("22/03/2012 intro\n"
" + 22/03/2012 body\n"
" + more body\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)