import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:<([a-zA-Z]+)(?:[ \\n]+[a-zA-Z]+(?:=([\"'])[\\-\\/_a-zA-Z0-9 &;.:?=#]*(\\3))?)*>(?1)?<\\/(\\2)>|[a-zA-Z0-9\\-_\\n &;.:?=#]+)+|<!--.*?-->)$";
final String string = "<a href=\"https://codegolf.stackexchange.com/2?b=2\">abc<span title=\"a\"></span></a><b><!--abc<b>--></b>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}