$re = '/^((?:<([a-zA-Z]+)(?:[ \n]+[a-zA-Z]+(?:=(["\'])[\-\/_a-zA-Z0-9 &;.:?=#]*(\3))?)*>(?1)?<\/(\2)>|[a-zA-Z0-9\-_\n &;.:?=#]+)+|<!--.*?-->)$/m';
$str = '<a href="https://codegolf.stackexchange.com/2?b=2">abc<span title="a"></span></a><b><!--abc<b>--></b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);