import re
regex = re.compile(r"^((?:<([a-zA-Z]+)(?:[ \n]+[a-zA-Z]+(?:=([\"'])[\-\/_a-zA-Z0-9 &;.:?=#]*(\3))?)*>(?1)?<\/(\2)>|[a-zA-Z0-9\-_\n &;.:?=#]+)+|<!--.*?-->)$", flags=re.MULTILINE)
test_str = "<a href=\"https://codegolf.stackexchange.com/2?b=2\">abc<span title=\"a\"></span></a><b><!--abc<b>--></b>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")