re = /^((?:<([a-zA-Z]+)(?:[ \n]+[a-zA-Z]+(?:=(["'])[\-\/_a-zA-Z0-9 &;.:?=#]*(\3))?)*>(?1)?<\/(\2)>|[a-zA-Z0-9\-_\n &;.:?=#]+)+|<!--.*?-->)$/m
str = '<a href="https://codegolf.stackexchange.com/2?b=2">abc<span title="a"></span></a><b><!--abc<b>--></b>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end