const regex = /^((?:<([a-zA-Z]+)(?:[ \n]+[a-zA-Z]+(?:=(["'])[\-\/_a-zA-Z0-9 &;.:?=#]*(\3))?)*>(?1)?<\/(\2)>|[a-zA-Z0-9\-_\n &;.:?=#]+)+|<!--.*?-->)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:<([a-zA-Z]+)(?:[ \\n]+[a-zA-Z]+(?:=(["\'])[\\-\\\/_a-zA-Z0-9 &;.:?=#]*(\\3))?)*>(?1)?<\\\/(\\2)>|[a-zA-Z0-9\\-_\\n &;.:?=#]+)+|<!--.*?-->)$', 'gm')
const str = `<a href="https://codegolf.stackexchange.com/2?b=2">abc<span title="a"></span></a><b><!--abc<b>--></b>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}