#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s).*\n(\d{4}-\d{2}-\d{2}:.*)"
Local $sString = "2020-05-20: Status update blah blah" & @CRLF & _
"2020-05-27: PO Issued blah blah" & @CRLF & _
"blah blah"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")