package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s).*\n(\d{4}-\d{2}-\d{2}:.*)`)
var str = `2020-05-20: Status update blah blah
2020-05-27: PO Issued blah blah
blah blah`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}