const regex = new RegExp('(?s).*\\n(\\d{4}-\\d{2}-\\d{2}:.*)', '')
const str = `2020-05-20: Status update blah blah
2020-05-27: PO Issued blah blah
blah blah`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}