$re = '`(?s).*\n(\d{4}-\d{2}-\d{2}:.*)`';
$str = '2020-05-20: Status update blah blah
2020-05-27: PO Issued blah blah
blah blah';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);