using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s).*\n(\d{4}-\d{2}-\d{2}:.*)";
string input = @"2020-05-20: Status update blah blah
2020-05-27: PO Issued blah blah
blah blah";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}