// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s).*\n(\d{4}-\d{2}-\d{2}:.*)").unwrap();
let string = "2020-05-20: Status update blah blah
2020-05-27: PO Issued blah blah
blah blah";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}