import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<script src=\\\"https://browser\\.sentry-cdn\\.com/([\\d\\.]+)*/bundle\\.min\\.js\\\"";
final String string = "<script src=\"https://browser.sentry-cdn.com/5.7.1/bundle.min.js\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}