#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\[\[File:[^|]*).*?(\]\])"
Local $sString = "[[File:My Image.png|400px|thumb|center|My Image]]" & @CRLF & _
"[[File:My Image.png|400px|thumb|center]] [[File:My Image.png|400px|thumb|center]]" & @CRLF & _
"[[File:My Image.png|400px|thumb]]" & @CRLF & _
"[[File:My Image.png|400px]]" & @CRLF & _
"[[File:My Image.png]]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")