re = /(\[\[File:[^|]*).*?(\]\])/
str = '[[File:My Image.png|400px|thumb|center|My Image]]
[[File:My Image.png|400px|thumb|center]] [[File:My Image.png|400px|thumb|center]]
[[File:My Image.png|400px|thumb]]
[[File:My Image.png|400px]]
[[File:My Image.png]]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end