const regex = /(\[\[File:[^|]*).*?(\]\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\[\\[File:[^|]*).*?(\\]\\])', 'g')
const str = `[[File:My Image.png|400px|thumb|center|My Image]]
[[File:My Image.png|400px|thumb|center]] [[File:My Image.png|400px|thumb|center]]
[[File:My Image.png|400px|thumb]]
[[File:My Image.png|400px]]
[[File:My Image.png]]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}