package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[\[File:[^|]*).*?(\]\])`)
var str = `[[File:My Image.png|400px|thumb|center|My Image]]
[[File:My Image.png|400px|thumb|center]] [[File:My Image.png|400px|thumb|center]]
[[File:My Image.png|400px|thumb]]
[[File:My Image.png|400px]]
[[File:My Image.png]]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}