import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[\\[File:[^|]*).*?(\\]\\])";
final String string = "[[File:My Image.png|400px|thumb|center|My Image]]\n"
+ "[[File:My Image.png|400px|thumb|center]] [[File:My Image.png|400px|thumb|center]]\n"
+ "[[File:My Image.png|400px|thumb]]\n"
+ "[[File:My Image.png|400px]]\n"
+ "[[File:My Image.png]]\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}