import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.?)(.?)(.?)(.?)(.?).?\\5\\4\\3\\2\\1$";
final String string = "a\n"
+ "ab\n"
+ "abba\n"
+ "abcdef\n"
+ "abcba\n"
+ "zufolo";
final String subst = "**palindrome**";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}