re = /^(.?)(.?)(.?)(.?)(.?).?\5\4\3\2\1$/m
str = 'a
ab
abba
abcdef
abcba
zufolo'
subst = '**palindrome**'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result