$re = '/^(.?)(.?)(.?)(.?)(.?).?\5\4\3\2\1$/m';
$str = 'a
ab
abba
abcdef
abcba
zufolo';
$subst = "**palindrome**";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;