use strict;
my $str = 'a
ab
abba
abcdef
abcba
zufolo';
my $regex = qr/^(.?)(.?)(.?)(.?)(.?).?\5\4\3\2\1$/mp;
my $subst = '**palindrome**';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";