import Foundation
let pattern = #"^(.?)(.?)(.?)(.?)(.?).?\5\4\3\2\1$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a
ab
abba
abcdef
abcba
zufolo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"**palindrome**"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)