const regex = /^(.?)(.?)(.?)(.?)(.?).?\5\4\3\2\1$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.?)(.?)(.?)(.?)(.?).?\\5\\4\\3\\2\\1$', 'gm')
const str = `a
ab
abba
abcdef
abcba
zufolo`;
const subst = `**palindrome**`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);