const regex = /(((https?:(?:\/\/)?)(?!(www\.)*youtube\.com|youtu\.be|(www\.|rover\.)*ebay\.com|(www\.)*amazon\.)[A-Za-z0-9.\-]+[A-Za-z0-9.\-]+)((?:\/[\+~%\/.\w\-_]*)?\??(?:[\-\+=&;%@.\w_]*)#?(?:[\w]*))?)/mi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((https?:(?:\\\/\\\/)?)(?!(www\\.)*youtube\\.com|youtu\\.be|(www\\.|rover\\.)*ebay\\.com|(www\\.)*amazon\\.)[A-Za-z0-9.\\-]+[A-Za-z0-9.\\-]+)((?:\\\/[\\+~%\\\/.\\w\\-_]*)?\\??(?:[\\-\\+=&;%@.\\w_]*)#?(?:[\\w]*))?)', 'mi')
const str = `https://youtube.com
https://www.amazon.com
https://www.notamazon.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}