import Foundation
let pattern = ##"(((https?:(?:\/\/)?)(?!(www\.)*youtube\.com|youtu\.be|(www\.|rover\.)*ebay\.com|(www\.)*amazon\.)[A-Za-z0-9.\-]+[A-Za-z0-9.\-]+)((?:\/[\+~%\/.\w\-_]*)?\??(?:[\-\+=&;%@.\w_]*)#?(?:[\w]*))?)"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://youtube.com
https://www.amazon.com
https://www.notamazon.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}