import re
regex = re.compile(r"(((https?:(?:\/\/)?)(?!(www\.)*youtube\.com|youtu\.be|(www\.|rover\.)*ebay\.com|(www\.)*amazon\.)[A-Za-z0-9.\-]+[A-Za-z0-9.\-]+)((?:\/[\+~%\/.\w\-_]*)?\??(?:[\-\+=&;%@.\w_]*)#?(?:[\w]*))?)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("https://youtube.com\n\n"
"https://www.amazon.com\n\n"
"https://www.notamazon.com\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")