re = /(((https?:(?:\/\/)?)(?!(www\.)*youtube\.com|youtu\.be|(www\.|rover\.)*ebay\.com|(www\.)*amazon\.)[A-Za-z0-9.\-]+[A-Za-z0-9.\-]+)((?:\/[\+~%\/.\w\-_]*)?\??(?:[\-\+=&;%@.\w_]*)#?(?:[\w]*))?)/mi
str = 'https://youtube.com
https://www.amazon.com
https://www.notamazon.com
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end